[AccessD] Naming Conventions

John W. Colby jwcolby at colbyconsulting.com
Mon Aug 9 19:21:55 CDT 2004


Well, if that is the ONLY place the I is used then probably not.  If down in
the following code I is used 47 times then yea, probably.

John W. Colby
www.ColbyConsulting.com 

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of Jim DeMarco
Sent: Monday, August 09, 2004 11:55 AM
To: Access Developers discussion and problem solving
Subject: RE: [AccessD] Naming Conventions


John,

Magic (unexplained) numbers are always problematic.  But if:

  i = 1 to lngRecordCount...

Should we still need to expand on i?

Jim DeMarco

-----Original Message-----
From: Colby, John [mailto:JColby at dispec.com]
Sent: Monday, August 09, 2004 11:49 AM
To: 'Access Developers discussion and problem solving'
Subject: RE: [AccessD] Naming Conventions


Counters count SOMETHING.  What is it counting?  WHY are you bothering to
count?  

It is exactly that thinking that leads to obfuscation.

JWC

-----Original Message-----
From: Arthur Fuller [mailto:artful at rogers.com]
Sent: Monday, August 09, 2004 11:34 AM
To: 'Access Developers discussion and problem solving'
Subject: RE: [AccessD] Naming Conventions


Exactly! The names ijk imply throwaway variables not of interest in
themselves -- mere counters. So there's nothing wrong IMO with

Dim i as Long, j as Long, k as Long

For I = 1 to 100
	For j = 1 to 10
		For k = 1 to 35
			DoSomething
		Next
		DoSomethingElse
	Next
	DoSomethingCompletelyDifferent
Next

What's the rumpus? (quoting my fave movie of all time, "Miller's
Crossing")

Arthur

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of DWUTKA at marlow.com
Sent: Monday, August 09, 2004 12:49 AM
To: accessd at databaseadvisors.com
Subject: RE: [AccessD] Naming Conventions


Ah, but i, j, k, etc. are a naming convention in and of itself.

We don't go:

LongIntegerSomethingOrOther

We go:
lngSomethingOrOther

or 

intSomethingOrOther

Because lng relates to a long integer....int to integer....

so, i, j, k relate to a counting integer.....

What's the fuss?

Now, this whole naming convention thing would be a completely different
story if the entire world programmed the same way.  But they don't.  No one
can agree on the exact same convention, so all this is, is many many 'camps'
saying 'my way is better, I better not ever have to read your code'.....

Drew

-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com
-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com


 



****************************************************************************
*******
"This electronic message is intended to be for the use only of the named
recipient, and may contain information from Hudson Health Plan (HHP) that is
confidential or privileged.  If you are not the intended recipient, you are
hereby notified that any disclosure, copying, distribution or use of the
contents of this message is strictly prohibited.  If you have received this
message in error or are not the named recipient, please notify us
immediately, either by contacting the sender at the electronic mail address
noted above or calling HHP at (914) 631-1611. If you are not the intended
recipient, please do not forward this email to anyone, and delete and
destroy all copies of this message.  Thank You".
****************************************************************************
*******

-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com






More information about the AccessD mailing list