[AccessD] Goodbye Leszynski/Reddick?

Salakhetdinov Shamil mcp2004 at mail.ru
Sun Jan 25 15:14:09 CST 2015


 Hi Dan --

It's just my current point of view - no any intentions here to start a "great anti-LRNC debate" :)

IMO it's very uncommon to use "cryptic" prefixes as .NET naming conventions. 
(FYI: As I have already noted here in this thread I was a strict adept of LRNC in MS Access/Office VBA).

Imagine somebody else, e.g. a young developer without any LRNC experience, would need to "decipher" your code to support it?

For your example, in .NET is common IMO to use the following naming conventions:

Objects
    Customer --> table of all customers
    CustomersList --> query for a list of customers
    CustomersForm or CustomersInfoForm --> form to manage customer info
    CustomersReport or CustomersInfoReport  --> report of customer info

Variables
    ID  in Customer class --> primary key for customer
    Name in Customer  class --> customer name in a string variable
    CustomersComboBox --> combobox of customers
    CustomerNameTextBox --> customer name in a text box
    CustomerAddedDate --> date customer added

And so on ...

I'd use the similar naming conventions in VBA: in MS Access Groups would help to keep related objects together and instantly available.
In .NET Intellisense makes any "cryptic" naming conventions (as LRNC) unneeded.

Thank you.

-- Shamil

Sun, 25 Jan 2015 10:18:34 -0600 from Dan Waters <df.waters at outlook.com>:
>I do the same.
>
>Example:
>
>Objects
>    tblCustomers --> table of all customers
>    qryCustomers --> query for a list of customers
>    frmCustomers --> form to manage customer info
>    rptCustomers --> report of customer info
>
>Variables
>    lngCustomerID --> primary key for customer
>    stgCustomer --> customer name in a string variable
>    cboCustomer --> combobox of customers
>    txtCustomer --> customer name in a text box
>    dteCustomerAdded --> date customer added
>
>And so on ...
>
>This makes objects easy to find by sorting the list by name.  I often have a
>set of objects which are a functional set so I design a name which
>identifies them all and they'll all be together in the list.
>
>In code, it's a big help to be able to see what the variable or object type
>is without having to 'figure it out' each time.  I'm now developing in .net
>and am using the same scheme. 
>
>Dan
>
>
>-----Original Message-----
>From:  accessd-bounces at databaseadvisors.com
>[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of Rocky Smolin
>Sent: Saturday, January 24, 2015 23:02 PM
>To: 'Access Developers discussion and problem solving'
>Subject: Re: [AccessD] Goodbye Leszynski/Reddick?
>
>I use the prefix to tell me what kind of object I'm working with -
>recordset, query, text box, combo box, report, form, etc.
>
>r
> 
>
>-----Original Message-----
>From:  accessd-bounces at databaseadvisors.com
>[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of Tony Septav
>Sent: Saturday, January 24, 2015 7:58 PM
>To: 'Access Developers discussion and problem solving'
>Subject: Re: [AccessD] Goodbye Leszynski/Reddick?
>
>Hey All
>Why not?? For Queries their names become CustAdd CustDel CustEdit CustFind
>It is intuitive, sorry I do not get the prefixes/suffixes. Maybe after all
>these years I have been missing the point. 
>
>Yes Gustav this list is addictive like the old American Television show
>"Cheers".
>
>Tony Septav
>Nanaimo, BC
>Canada
>
>
>
>
>-----Original Message-----
>From:  accessd-bounces at databaseadvisors.com
>[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of Salakhetdinov
>Shamil
>Sent: January-24-15 5:11 AM
>To: Access Developers discussion and problem solving
>Subject: Re: [AccessD] Goodbye Leszynski/Reddick?
>
> Hi Gustav --
>
>Currently I name tables in singular mode and I don't have any
>prefixes/suffixes used with their names. For queries I still use LRNC
>prefixes:
>
>- qsel
>- qapp
>- qupd
>- qdel
>...
>
>I have got "addicted" to use the LRNC queries prefixes since I have read
>Stan Leszynski "MS Access 97 Expert Solutions" book -
>http://tinyurl.com/luqfh8h
>
>But I'm open to accept any other modern naming conventions where "type"
>prefixes are not used at all.
>
>Thank you.
>
>-- Shamil
>
>
>Sat, 24 Jan 2015 09:57:10 +0000 from Gustav Brock < gustav at cactus.dk >:
>>Hi Shamil
>>
>>How do you name tables and queries, please?
>>
>>/gustav
>>
>>________________________________________
>>Fra:  accessd-bounces at databaseadvisors.com <
>accessd-bounces at databaseadvisors.com > på vegne af Salakhetdinov Shamil <
>mcp2004 at mail.ru >
>>Sendt: 21. januar 2015 16:34
>>Til: Access Developers discussion and problem solving
>>Emne: Re: [AccessD] Goodbye Leszynski/Reddick?
>>
>> HI Gustav --
>>
>>I have also abandoned LRNC in VBA for quite some time now (and I was a
>strict "LRNC-adept" in 1990-es). The naming conventions I'm using for VBA
>look similar to yours but for local variables and for functions'/subs'
>parameters, private subs,functions, properties I'm using lowercase letters
>in the beginning, and I'm using 'm_"  prefix  for (class) module level
>variables.
>>
>>Thank you.
>>
>>-- Shamil
>>--
>>AccessD mailing list
>> AccessD at databaseadvisors.com
>> http://databaseadvisors.com/mailman/listinfo/accessd
>>Website:  http://www.databaseadvisors.com
>
>--
>AccessD mailing list
>AccessD at databaseadvisors.com
>http://databaseadvisors.com/mailman/listinfo/accessd
>Website:  http://www.databaseadvisors.com
>
>
>-----
>No virus found in this message.
>Checked by AVG -  www.avg.com
>Version: 2015.0.5645 / Virus Database: 4273/8984 - Release Date: 01/23/15
>
>
>--
>AccessD mailing list
>AccessD at databaseadvisors.com
>http://databaseadvisors.com/mailman/listinfo/accessd
>Website:  http://www.databaseadvisors.com
>
>
>-- 
>AccessD mailing list
>AccessD at databaseadvisors.com
>http://databaseadvisors.com/mailman/listinfo/accessd
>Website:  http://www.databaseadvisors.com
>
>
>-- 
>AccessD mailing list
>AccessD at databaseadvisors.com
>http://databaseadvisors.com/mailman/listinfo/accessd
>Website:  http://www.databaseadvisors.com



More information about the AccessD mailing list