[AccessD] Goodbye Leszynski/Reddick?

Salakhetdinov Shamil mcp2004 at mail.ru
Mon Jan 26 01:36:17 CST 2015


 Hi Dan --

<<<
Now, when working in Access VBA, I feel like I'm driving 
a car that doesn't have any gauges! 
>>>
So true.

<<<
My .Net work so far is in windows forms only in VB, and those apps are very form-centric. 
So, I just haven't seen an advantage to setting up a class for a Customer, or part, or almost anything else. 
>>>
Do you use .NET Windows Forms bound forms with BindingSource and BindingNavigator and ADO.NET datasets?

<<<
Speaking of which, I have to go drive that car right now ... ;-)
>>>
That'd keep you concentrated on the road - not bad after all :)
(I used to switch between a car with automatic and manual transmissions, the one with responsive driving wheel, throttle, clutch and brakes and the one with all that levers being very rigid, even used manual transmission manipulating it by my left hand while driving abroad a right-driving-wheel car keeping driving on the left side of the road - it was very refreshing! :) )

Thank you.

-- Shamil

Sun, 25 Jan 2015 19:31:25 -0600 from Dan Waters <df.waters at outlook.com>:
>Hi Shamil,
>
>Thanks for your thoughtful comments!  No wars here ... :-)
>
>My .Net work so far is in windows forms only in VB, and those apps are very form-centric.  So, I just haven't seen an advantage to setting up a class for a Customer, or part, or almost anything else.  I'm going to guess that a widespread use of classes is more prevalent in web programming.  So far, my only classes are for Session values (which are set when the app is opened and don't change), Utility procedures, Global procedures, People procedures, and a Progress bar.
>
>I don't think a new person would find my naming style cryptic.  Except for the prefix, I always use full words.  A form is named 'frmOpenItemsList', or 'frmProfileReplaceManager'.  A report is named 'rptProfileLocationsPeople' or 'rptLogonActivityIndividual'.  So, with a few prefixes I think my code is quite readable.  For objects, I showed a prefix and you showed a suffix - those two techniques are about the same.  For Classes and Modules, I do not use prefixes, but might use names that contain the same word if helpful.
>
>And, I am 'in love' with intellisense in VS!!  Now, when working in Access VBA, I feel like I'm driving a car that doesn't have any gauges!  Speaking of which, I have to go drive that car right now ... ;-)
>
>Thanks!
>Dan
>
>-----Original Message-----
>From:  accessd-bounces at databaseadvisors.com [mailto:accessd-bounces at databaseadvisors.com] On Behalf Of Salakhetdinov Shamil
>Sent: Sunday, January 25, 2015 15:14 PM
>To: Access Developers discussion and problem solving
>Subject: Re: [AccessD] Goodbye Leszynski/Reddick?
>
> Hi Dan --
>
>It's just my current point of view - no any intentions here to start a "great anti-LRNC debate" :)
>
>IMO it's very uncommon to use "cryptic" prefixes as .NET naming conventions. 
>(FYI: As I have already noted here in this thread I was a strict adept of LRNC in MS Access/Office VBA).
>
>Imagine somebody else, e.g. a young developer without any LRNC experience, would need to "decipher" your code to support it?
>
>For your example, in .NET is common IMO to use the following naming conventions:
>
>Objects
>    Customer --> table of all customers
>    CustomersList --> query for a list of customers
>    CustomersForm or CustomersInfoForm --> form to manage customer info
>    CustomersReport or CustomersInfoReport  --> report of customer info
>
>Variables
>    ID  in Customer class --> primary key for customer
>    Name in Customer  class --> customer name in a string variable
>    CustomersComboBox --> combobox of customers
>    CustomerNameTextBox --> customer name in a text box
>    CustomerAddedDate --> date customer added
>
>And so on ...
>
>I'd use the similar naming conventions in VBA: in MS Access Groups would help to keep related objects together and instantly available.
>In .NET Intellisense makes any "cryptic" naming conventions (as LRNC) unneeded.
>
>Thank you.
>
>-- Shamil
>
>Sun, 25 Jan 2015 10:18:34 -0600 from Dan Waters < df.waters at outlook.com >:
>>I do the same.
>>
>>Example:
>>
>>Objects
>>    tblCustomers --> table of all customers
>>    qryCustomers --> query for a list of customers
>>    frmCustomers --> form to manage customer info
>>    rptCustomers --> report of customer info
>>
>>Variables
>>    lngCustomerID --> primary key for customer
>>    stgCustomer --> customer name in a string variable
>>    cboCustomer --> combobox of customers
>>    txtCustomer --> customer name in a text box
>>    dteCustomerAdded --> date customer added
>>
>>And so on ...
>>
>>This makes objects easy to find by sorting the list by name.  I often 
>>have a set of objects which are a functional set so I design a name 
>>which identifies them all and they'll all be together in the list.
>>
>>In code, it's a big help to be able to see what the variable or object 
>>type is without having to 'figure it out' each time.  I'm now 
>>developing in .net and am using the same scheme.
>>
>>Dan
<<< skipped >>>
>


More information about the AccessD mailing list