[AccessD] Programming conventions... was Naming Conventions

Scott Marcus marcus at tsstech.com
Thu Aug 12 06:35:39 CDT 2004


Why not use an Exit statement?

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of
DWUTKA at marlow.com
Sent: Wednesday, August 11, 2004 6:07 PM
To: accessd at databaseadvisors.com
Subject: RE: [AccessD] Naming Conventions


I remember that thread.  I said I used Goto's when needed.  I honestly don't
use them very often.  I use them in errorhandling, and I use them in
particular loops where I want a loop with various conditions.  But again, I
don't use them to jump code around for willy nilly reasons.

Drew

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of Scott Marcus
Sent: Wednesday, August 11, 2004 3:34 PM
To: Access Developers discussion and problem solving
Subject: RE: [AccessD] Naming Conventions


Drew,

I remember talking about spaghetti code around a year or so ago. Wasn't it
you who said that you used goto's liberally?

Now I'm starting to sound like a troll. I'll stop.

Scott Marcus

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of
DWUTKA at marlow.com
Sent: Wednesday, August 11, 2004 4:27 PM
To: accessd at databaseadvisors.com
Subject: RE: [AccessD] Naming Conventions


Still don't see what point you are trying to make.  There are people on the
list (other then me) who have said they use i, j, k.  Then there are people
that use long variable definitions.  

Going either way is leaving the client a 50/50 shot as to having the next
developer use the same methods.

Do you understand what I am saying JC?  If everyone used the same methods,
and I was the only person in the world that was different, then I would have
to change, because it doesn't make logic sense, and I would be hurting my
clients.  But I'm NOT the lone wolf on this.  There IS NO world wide
standard, that everyone else adheres too.  There are camps.  Camps of people
that feel one way or the other.  If you belong to Camp A, you can't possible
write code to satisfy other Camp A folks, and Camp B, and Camp C, etc.  If
you stick to Camp A, your client has the same chance of getting a new
developer from the right camp, no matter what camp you decide to align with.

Drew

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of John W. Colby
Sent: Tuesday, August 10, 2004 8:34 PM
To: 'Access Developers discussion and problem solving'
Subject: RE: [AccessD] Naming Conventions


>Actually, I find it easier to remember that I'm using I

Which is unfortunately the crux of the matter.  It's all about "I".
Programming is supposed to be about the client, THEIR software, THEIR
maintenance costs if you are hit by a bus.  NOT about "I find it easier to
remember".  

When I come in to maintain your software I don't have your memories to work
with!

John W. Colby
www.ColbyConsulting.com 

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of DWUTKA at marlow.com
Sent: Tuesday, August 10, 2004 5:16 PM
To: accessd at databaseadvisors.com
Subject: RE: [AccessD] Naming Conventions


Actually, I find it easier to remember that I'm using i, then it is to
remember that I am using
lngSomeLongDrawnOutCompletelyMeaninglessToTheCompilerNameSoThatSomeoneWhoIsT
ooLazyToReadTheCodeLogicCanImpressAClientThatTheyKnowAParticularVariableRepr
esentsXYZ

Drew

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of Scott Marcus
Sent: Tuesday, August 10, 2004 6:12 AM
To: Access Developers discussion and problem solving
Subject: RE: [AccessD] Naming Conventions


There are plenty of other things that I would rather fill my mind with when
developing and debugging code than remembering in each line of code(in the
loop) that 'i' is the employee type and 'j' is the employee counter.

Wouldn't you agree that it is hard enough sometimes just to follow the logic
of the code you are working on let alone remembering these variable
interpretations?  

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of Susan Harkins
Sent: Monday, August 09, 2004 9:39 PM
To: 'Access Developers discussion and problem solving'
Subject: RE: [AccessD] Naming Conventions


Just a slight aside here, but you're gonna have to read the rest of the
statement anyway -- if you're counting something, you still need the rest of
the statement to figure out the rest -- the variable name itself is NOT
going to give you all the information you need. You still need the rest of
the statement. Not a for or an against, just thought I'd mention it... 

Susan H. 

Even 'intI' means little more than 'i'. Like you said, something like
'intEmployeeCounter' is easy to understand. Just to be even more clear, take
the following into consideration...


-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com


-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com
-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com



-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com
-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com


-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com
-- 
_______________________________________________
AccessD mailing list
AccessD at databaseadvisors.com
http://databaseadvisors.com/mailman/listinfo/accessd
Website: http://www.databaseadvisors.com





More information about the AccessD mailing list