[AccessD] Naming Conventions

Scott Marcus marcus at tsstech.com
Mon Aug 9 09:37:53 CDT 2004


Ouch, John...pretty harsh, but exactly right!

Even 'intI' means little more than 'i'. Like you said, something like 'intEmployeeCounter' is easy to understand. Just to be even more clear, take the following into consideration...

strEmployeeList(i,j) 'what does i and j stand for?
strEmployeeList(intI, intJ) 'still, what does intI and intJ stand for?
strEmployeeList(intEmployeeType, intEmployeeCounter) 'seems understandable to me

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com]On Behalf Of Colby, John
Sent: Monday, August 09, 2004 9:55 AM
To: 'Access Developers discussion and problem solving'
Subject: RE: [AccessD] Naming Conventions


So what do I use for a counting byte?  Or a counting long?  The naming
convention I use (yes I realize that is I) has three character prefixes for
not only objects but data types as well.  Your point about "the whole world
doesn't program the same way" is of course valid.  But to program with the
convention I use I or J or K is NOT a valid variable?  The old style coding
that used I or J or K was intentionally, with malice and forethought
replaced with meaningful names precisely because trying to read such code
sucks bigtime.  And yes, I realize that those who use I, J and K make wishy
washy claims that it is actually more efficient.  I have programmed in C and
I can write "more efficient" code that even an experienced C programmer
can't interpret.  Just because you can doesn't mean you should!

The whole point of a naming convention is to be able to read the name and
see what it is for.  Yes, I MAY be interpreted "automatically" as a counting
integer (by YOU), but counting WHAT?  Is it the row of a one dimension
array?  Or the row counter of a two dim array?  or a three dim array?  Or a
collection?  I is, you have to admit, pretty much useless in telling me
anything.  If I want to know, I have to go look at the dim, statement, then
I have to go look at the For Next row, just to find out what I does for me.

So what you are saying in your argument is that you simply don't care about
those who come behind.  It works for you and that  when you are not
maintaining the code why should you care?




More information about the AccessD mailing list