[AccessD] Naming Conventions

Arthur Fuller artful at rogers.com
Mon Aug 9 10:33:31 CDT 2004


Exactly! The names ijk imply throwaway variables not of interest in
themselves -- mere counters. So there's nothing wrong IMO with

Dim i as Long, j as Long, k as Long

For I = 1 to 100
	For j = 1 to 10
		For k = 1 to 35
			DoSomething
		Next
		DoSomethingElse
	Next
	DoSomethingCompletelyDifferent
Next

What's the rumpus? (quoting my fave movie of all time, "Miller's
Crossing")

Arthur

-----Original Message-----
From: accessd-bounces at databaseadvisors.com
[mailto:accessd-bounces at databaseadvisors.com] On Behalf Of
DWUTKA at marlow.com
Sent: Monday, August 09, 2004 12:49 AM
To: accessd at databaseadvisors.com
Subject: RE: [AccessD] Naming Conventions


Ah, but i, j, k, etc. are a naming convention in and of itself.

We don't go:

LongIntegerSomethingOrOther

We go:
lngSomethingOrOther

or 

intSomethingOrOther

Because lng relates to a long integer....int to integer....

so, i, j, k relate to a counting integer.....

What's the fuss?

Now, this whole naming convention thing would be a completely different
story if the entire world programmed the same way.  But they don't.  No
one can agree on the exact same convention, so all this is, is many many
'camps' saying 'my way is better, I better not ever have to read your
code'.....

Drew




More information about the AccessD mailing list